HELP !! HELP !! Transmission and engine problems

Discussion of Infiniti's amazing (and underrated) sport-luxury crossovers, the EX35 and EX37. For 2014, the EX series will be renamed QX50, in line with Ininfiit's new naming conventions.
Johnnydangerus
Posts: 23
Joined: Sat Dec 05, 2020 10:30 pm
Car: 2010 Infiniti EX35 Journey AWD premium package tech package. Obsidian black; Tan. 18" stk Michilin Primacy a/s. Remote start.
Location: Northeast Michigan

Re: HELP !! HELP !! Transmission and engine problems

Postby Johnnydangerus » Sat Dec 12, 2020 1:15 pm

I planned on taking a copy due to the one saying fix leak even out of warranty and if non payment of customer. I learned that knowledge is key with cars. But like anything there's tricks to the trade. Bty I ran the car this morning to warm transmission before performing the idel relearn and the only light was for low gas gauge which changed as I drove. Light went out when I shut off an started again. Car has less hesitation for sure but still was just little erratic at first couple start ups. Not sure if I should relearn or just wait until I take it in for the reprogramming? And I did move butterfly for those who wonder just be gentle when you are releasing the pressure of the butterfly after wiping out the carbon build up. Otherwise they want to slam shut. My case I did not want to remove them and damage the gaskets or have issues with bolts holding throttel body in place so cleand them without taking them off.


User avatar
VStar650CL
Posts: 2015
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: HELP !! HELP !! Transmission and engine problems

Postby VStar650CL » Sat Dec 12, 2020 1:19 pm

If an ECM repro is part of the TSB then don't bother with the relearn, it will be done as part of the reprogramming routine. If it's only other ECU's and not the ECM, then a relearn is worthwhile.

Johnnydangerus
Posts: 23
Joined: Sat Dec 05, 2020 10:30 pm
Car: 2010 Infiniti EX35 Journey AWD premium package tech package. Obsidian black; Tan. 18" stk Michilin Primacy a/s. Remote start.
Location: Northeast Michigan

Re: HELP !! HELP !! Transmission and engine problems

Postby Johnnydangerus » Sat Dec 12, 2020 8:21 pm

I was unable to read the detailed information so if all it will do is rest it basically then that can't hurt. My issue with the shifting is still noticeable. I can feel the difference in the cleaning right off the get. Seems the system is confused for sure. Want to say 50/50 chance when I start the car which mood it will be in. Lol. Either happens or doesn't. Drove like a champ to the store back home. Store few hrs later but when I left the store I could tell pulling out it was up to its games. Late downshift is my big tell all. I did notice something curious in some pics I took of what I called fuse box #1. If you rotate it 180 degrees to the right in bottom left you can make out what looks like exposed wires? They are running along the top of the passenger wheel well or fender. I'll be tearing into that tomorrow. Hopefully I can get some better pics without removing to much first and see what I have to deal with.
Attachments
20201209_223913~3.jpg
20201209_223913~2.jpg

User avatar
VStar650CL
Posts: 2015
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: HELP !! HELP !! Transmission and engine problems

Postby VStar650CL » Sat Dec 12, 2020 9:10 pm

Yep. Not sure it's hurting anything, but that's definitely an exposed wire bundle. Looks to be in the E-Harness (Engine Room, not EGI) but it's hard to tell without a better reference.

Johnnydangerus
Posts: 23
Joined: Sat Dec 05, 2020 10:30 pm
Car: 2010 Infiniti EX35 Journey AWD premium package tech package. Obsidian black; Tan. 18" stk Michilin Primacy a/s. Remote start.
Location: Northeast Michigan

Re: HELP !! HELP !! Transmission and engine problems

Postby Johnnydangerus » Sat Dec 12, 2020 10:41 pm

I could only find for 08 ex35 but is the issue to a T. ITB11-018a. I belive they should still perform the service id hope.

User avatar
VStar650CL
Posts: 2015
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: HELP !! HELP !! Transmission and engine problems

Postby VStar650CL » Sun Dec 13, 2020 7:21 am

What works on an '08 may not extrapolate to a '10, but it still never hurts to have the latest firmware revs in your controllers. The updates are invariably bug-fixes, so you're reducing the chances that any bug is responsible for your issues.


Return to “Infiniti EX35 / EX37 and QX50 Forum”