DE-K with DE top end?

Discuss topics related to the VQ series engine.
MrWright
Posts: 6
Joined: Fri Oct 07, 2011 8:25 am
Car: 95 Nissan Maxima

DE-K with DE top end?

Postby MrWright » Mon Oct 10, 2011 12:00 pm

I recently purchased a 1995 Maxima GLE with a blown motor. I purchased a used motor with 108000 miles on it. The motor they sent me was from a 2000 I30. I switched the valve covers, upper and lower intake manifold, front exhaust manifold, and modified my vacuum so it would work around the water pipe from the I30. Now the car runs great when it's cold, but as soon as it warms up, it runs like crap. This is my first Nissan, and I've read alot of the forums here. I was wondering if anyone could give me some advice on what to do next. I keep getting EGR, and MAF codes. I still have all the I30 parts so I can do any necessary swaps. I'm just not sure where to go next. I really need this car up and running. Do I need to put any of the DE-K parts back on to get it running right?


User avatar
evildky
Moderator
Posts: 14797
Joined: Sat Jan 31, 2004 9:23 pm
Car: 71 240ZT, 87 300ZXN/A-T, 06 350Z GT, Tundra TRD RW
Location: Louisville, KY
Contact:

Re: DE-K with DE top end?

Postby evildky » Thu Oct 10, 2013 9:04 am

Sounds like it's running pig rich, could be the egr stuck open, could be a bad or dirty maf, could also be the chts.

User avatar
cincysilvias14
Posts: 41
Joined: Tue Aug 21, 2012 12:33 pm
Car: 2008 350z touring
2004 350z enthusiast
Location: Cincinnati, OH

Re: DE-K with DE top end?

Postby cincysilvias14 » Tue Aug 11, 2015 8:31 pm

^that clean the maf to start(easiest) might want to invest in an air/fuel gauge.


Return to “VQ30DE / VQ35DE / VQ35HR Forum”

cron