'95 J30 starter/tranny connections, relays, SERIOUS problem!!

General discussion forum for J30 and M30 owners!
oneinagoogolplex
Posts: 1
Joined: Tue Apr 06, 2010 4:21 am

'95 J30 starter/tranny connections, relays, SERIOUS problem!!

Postby oneinagoogolplex » Tue Apr 06, 2010 4:33 am

Okay the other day Im out getting food and I get in my car to go home, turn it on no problem, put it in reverse, go a couple feet in reverse and I hear a sound when I switch to drive, sounded like the starter kicking on possibly something in the tranny, really not sure at this point. Anyways, I dont think anything off it, didnt sound like a problem, well I stop to get gas and when i turn my key off and take it out, the starter never stopped runnning!!! so all i hear is the starter and flywheel spinning, and then I just turn the key back to on, and the car comes on fine. Well no when I change gears between P-D I hear that click noise and the starter seems to turn on, well I replaced the starter, didnt help, replace the starter relay today, didnt help, now Im hearing it may be in the tranny or the relay switch, or maybe a switch that tells the starter to come on is broken..I have NO CLUE and I need someones help bad!!


User avatar
driverdriver
Posts: 3650
Joined: Fri Aug 01, 2003 10:36 am
Car: NICO's longtime resident Canuck!!!
Contact:

Postby driverdriver » Tue Apr 06, 2010 3:04 pm

First step is to pull any stored fault codes from the ECU, Have you done that?

There is sticky on the J30 forum page on how to do that depending on what year your car was made.

Report back on the codes.

qship96
Posts: 6624
Joined: Sun Nov 24, 2002 11:31 am
Car: 1996 Q45

Re: (driverdriver)

Postby qship96 » Tue Apr 06, 2010 4:33 pm

starter relay stuck "on"?????

Dickaroo
Posts: 1
Joined: Tue Apr 06, 2010 6:37 pm
Car: Infinity J30 3.0L 6 CYL / Chevy S10 pickapoo 2.2L 4 CYL

Re: '95 J30 starter/tranny connections ... (oneinagoogolplex)

Postby Dickaroo » Tue Apr 06, 2010 6:43 pm



Please let me know what you find out about this problem. Unbelievable, I have a 93 J30 with the same problem for 2 weeks now when changing the gears, also the car stayed running one time when I removed the keys! It got so bad today that it did it every time when changing from reverse to drive or parking and vice versa. Very loud thump and sounds like the gears are all just flying loose inside the tranny or in the motor, it also sounds like maybe it's just the starter kicking in. Very strange, I’ve never heard anything like this in any car. I'm kind of scared of mechanics in this economy since with a problem like this they can just about tell you anything , when in fact it could be something small, that's why I goggled up this thread as I always try to fix things myself first. Anyway, at this point the only thing I can also add, and I don’t see how this would be the reason for the problems, however highly coincidental is the fact that the problem started happening little later on the same day after I changed the oil, put platinum NGK spark plugs and greased alot of joints and such under the car, due to already visible rust and wear. I was careful not to get any oil on vital parts around the engine. These things are too unlikely to have caused this problem, but indeed very coincidental that it only started happening after I did this. I will keep you posted, please do the same if you find out more. THANK YOU!


cablerat
Posts: 2
Joined: Thu Apr 15, 2010 4:00 pm
Car: 1997-j30

Re: '95 J30 starter/tranny connections, relays, SERIOUS prob

Postby cablerat » Thu Apr 15, 2010 4:09 pm

My j30 did the samething today . If you get a fix please post thanks .

cablerat
Posts: 2
Joined: Thu Apr 15, 2010 4:00 pm
Car: 1997-j30

Re: '95 J30 starter/tranny connections, relays, SERIOUS prob

Postby cablerat » Sun Apr 18, 2010 6:23 am

I FIXED IT. THE STARTER HOLD RELAY was bad.Its the small black relay on the pass side You can remove it to see if that is your problem. My car runs fine without it.Pull and check.

mschaublin001
Posts: 3
Joined: Sat Aug 21, 2010 1:16 pm
Car: 1995 Infiniti J30

Re: '95 J30 starter/tranny connections, relays, SERIOUS prob

Postby mschaublin001 » Wed May 22, 2013 8:57 pm

Worked for me. Thanks for posting.

mmcm
Posts: 1
Joined: Sat Dec 01, 2012 12:50 pm
Car: Infiniti 1995 J30T

Re: '95 J30 starter/tranny connections, relays, SERIOUS problem!!

Postby mmcm » Mon Nov 09, 2020 10:30 pm

Hello all. As a woman with no mechanical background, I've found this forum SO helpful! Searching the posts of all the great contributors here I've been able to solve a number of problems. I had this same problem with my (still running:) 1995 J30T. I pulled up to the gas station, turned the key off and the starter kept running. Turned the key on and the car started up. Was able to drive home, when I tried to put it in Park or Neutral there was a terrible sound from the transmission. Sat there in Drive with my foot on the brake until a friend could come over and remove a battery terminal to turn it off. I found this post, had someone help me remove the starter hold relay, and the car now works fine. The Infiniti dealer here in Victoria says there are none available in Canada, will take quite a few weeks to get one. The parts manager didn't know what it does. So, my questions are: what is the function of the starter hold relay? Is it necessary? Is is the type of part I can buy from another company (he mentioned that Bosch makes good relays ...).


Return to “J30 Forum / M30 Forum”