2009 Versa whining noise

General Discussion forum for Versa Owners
kdw3290
Posts: 3
Joined: Fri Sep 21, 2018 6:57 pm
Car: 2009 Versa

2009 Versa whining noise

Postby kdw3290 » Fri Sep 21, 2018 7:03 pm

I have a 2009 Versa. There is a whinig noise when I first accelerate then it goes away, and again when I start to brake it whines, but stops when I completely stop. It is a CVT transmission. There is no slipping, it accelerates fine, shift fines(auto), no lost of power uphill or down.
I have read that flushing the CVT fluid helps the get rid of the noise. It has 83,000 miles on it and brought it used a few weeks ago.
I have had the serpertine belt changed which was the original, new oil, and battery.

Anyone have any clue what may be wrong....hoping not a new trans


amc49
Posts: 1168
Joined: Mon Jun 19, 2017 7:24 pm
Car: '11 Versa
'17 Altima

Re: 2009 Versa whining noise

Postby amc49 » Sat Sep 22, 2018 1:53 am

When the CVT whines it is slipping, although it may not be enough to tell yet. Later it will.

Watch your a/c, if you have the vane type compressor they whine when older and can be normal. Turn it off for a bit while the whine has showed up to tell. My '11 does it.

kdw3290
Posts: 3
Joined: Fri Sep 21, 2018 6:57 pm
Car: 2009 Versa

Re: 2009 Versa whining noise

Postby kdw3290 » Sun Sep 23, 2018 7:56 am

AMC49 did your 11 transmission fail. if so how long from the time of the whine did it go. I check the ac, the whine is there when the ac is off.


Return to “Versa General Chat”